Control de Flujo:Alternativa Multiple



Con frecuencia es necesario que existan mas de dos elecciones posibles. Este problema podría resolver con varias condiciones simples/dobles anidadas o bien con la estructura que veremos a continuación. La alternativa múltiples evaluara una expresión que podrá tomar n valores distintos, 1, 2 ,3 .. n.

algoritmo

segun_sea expresion (E) hacer
e1:
accion 1
accion 2
accion n
e2:
accion 1
accion 2
accion n
en:
accion 1
accion 2
accion n
si-no
accion 1
accion 2
accion n
fin_segun

El funcionamiento es sencillo,  Se toma la expresión E, si <<E>> es igual a e1 entonces se ejecuta el grupo de acciones dentro de <<e1>>.   Si <<E>> es igual a <<e2>> se ejecuta el grupo de acciones dentro de <<e2>>. Si <<E>> es igual a <<en>> entonces se ejecutan las n acciones de <<en>>. En el caso de que <<E>> no sea igual a ninguno de los casos se ejecuta el bloque de acciones de <<si-no>>.


ejemplo
inicio
escribir('1. Saludar en español')
escribir('2. Saludar en ingles')
escribir('Ingrese un numero')
leer(E)
segun_sea (E) hacer
1:
escribir('Hola')
2:
escribir('Hello')
si-no:
escribir('Error')
fin_segun
fin