Control de Flujo:Alternativa Doble


La estructura de alternativa simple, es muy limitada y normalmente se necesitara una estructura que permita elegir entre dos opciones o alternativas, en función del cumplimiento de una determinada condición.

En la alternativa doble tenemos la opción de realizar una acción en el caso de que la condición no se cumpla

pseudocódigo

si <condicion> entonces
<accion 1>
<accion 2>
<accion n>
si_no
<accion 1>
<accion 2>
<accion n>
fin_si

Observe que en el pseudocodigo las acciones que dependen de <<entonces>> y <<si_no>> están indentadas en relación con las palabras <<si> y <<fin_si>>; indentar aumenta la legibilidad del código y es una buena practica para representar no tan solo algoritmos, sino también en el lenguaje de programación que vayas a utilizar (el que sea)

Ejemplo

si 3<1 entonces
escribir('tres es menor a uno')
si-no
escribir('tres no es menor a uno')
fin_si