Control de Flujo II:Sentencia Interrumpir


En ocasiones se desea terminar un bucle en un lugar determinado del cuerpo del bucle en vez de esperar que termine el bucle como estaba determinado. Un uso común de la sentencia interrumpir(break) es en el la sentencia segun_sea(switch)

ejemplo
leer (a)
segun_sea (a) hacer
1:
escribir('a es 1')
interrumpir
2:
escribir('a es 2')
interrumpir
si-no:
escribir('a no es 1 o 2')
fin_segun

Para que hacer esto ?  para que cuando se ejecute un cuerpo de algunas de las condiciones del segun_sea, salga del bucle luego de finalizar de ejecutar el bloque. Esto evita que se sigan evaluando las diferentes condiciones.